ssrs error: System.Data.OracleClient requires Oracle client software version 8.1.7 or greater – simple fix

Memorials of Old Wiltshire - Raising the Leaning Stone at StonehengeA quick post on a quick fix.

I installed Sql Server Reporting Services 2008 R2 on the report server, then installed Oracle client 11.2.0.4.

I copied across a valid tnsnames.ora file, and verified connectivity with both sqlplus and tnsping.

However, trying to connect to one of the Oracle databases from within SSRS I got:

System.Data.OracleClient requires Oracle client software version 8.1.7 or greater

…helpfully highlighted in an angry red.

Fix is fairly straightforward – SSRS hadn’t picked up the change to %PATH% done by the Oracle install yet, so the fix was to re-start the SSRS service.

Pic: From an old out-of-copyright book called ‘Memorials of Old Wiltshire’

Advertisements