opatch error: Perl lib version (v5.8.3) doesn't match executable version (v5.6.1) at x:oracle…

Got the following error:

C:oracleora92OPatch>perl opatch.pl version
Perl lib version (v5.8.3) doesn’t match executable version (v5.6.1) at x:oracle
10.2.0perl5.8.3lib/MSWin32-x86-multi-thread/Config.pm line 32.
Compilation failed in require at x:oracle10.2.0perl5.8.3lib/MSWin32-x86-mul
ti-thread/lib.pm line 6.
BEGIN failed–compilation aborted at x:oracle10.2.0perl5.8.3lib/MSWin32-x86
-multi-thread/lib.pm line 6.
Compilation failed in require at opatch.pl line 88.
BEGIN failed–compilation aborted at opatch.pl line 88.

Kind of obvious, but the fix here is to set your PERL5LIB variable correctly…

C:oracleora92OPatch>set PERL5LIB=C:perllib
C:oracleora92OPatch>perl opatch.pl version

Oracle Interim Patch Installer version 1.0.0.0.57
Copyright (c) 2007 Oracle Corporation. All Rights Reserved..

We recommend you refer to the OPatch documentation under
OPatch/docs for usage reference. We also recommend using
the latest OPatch version. For the latest OPatch version
and other support related issues, please refer to document
293369.1 which is viewable from metalink.oracle.com

OPatch Version: 1.0.0.0.57

Advertisements